Hardver Történet

UPinak volt egyszer régen-régen-régen egy nem túl meggondolt ötlete, miszerint egyszer majd megírja az Apocalypse hardware-történetét. Nos, arra gondoltam, nyithatnánk egy szavazó-oldalt, ahol lehet gyűjteni a szavazatokat UPi számára, támogatásul, hogy egyszer ez a rég remélt oldal megszülethessen. És akkor már azt is le lehetne írni, hogy hogy jött a webszerver-ötlet, meg később a wiki, meg ilyesmi.


Első fejezet – Kábelet tessék!

Gyertek gyerekek, üljetek le, mondok nektek egy mesét, aztán közben kuss legyen nagyon.

Egyszer volt, hol nem volt, voltam egyszer a UPi. Volt nekem egy kicsiny lakhelyem, amely fel volt szerelve pattintott lámpa-korszak minden kényelmével: volt benne gáz is, villany is, víz is, szklerózis. És telefon, amelyen keresztül a bitek vadul, 56k/sec-cel áramlottak a BME betárcsázós adatközpontjának irányából.

Amikor azt írom, hogy "áramlottak", az persze viszonylag rosszul fejezi ki a helyzetet: az "idegtépően lassan csorogtak le- s fölfele" talán közelebb járna a valósághoz. Ez persze mind relatív: a modemezést még a "hőskorban", a BBS-ek idejében kezdtem. Akkoriban egy 2400 baudos modemmel voltam felszerelve (amit ki is tiltottak az elite BBS-ekről mind egy szálig). Szépen lehetett látni a képernyőn, ahogy a byte-ok sodródnak irányomba, mint a moszat az óceánparton. Amikor megállt a szöveg a képernyőn, szinte érezni lehetett, ahogy a modem gyökér hibajavító algoritmusai küzdenek a Fatáv által ingyen és bérmentve szolgáltatott vonalzajjal.

Szóval, a lassúságot megszoktam, de meg nem szerettem, mert nem volt kötelező. Gondoltam hát egyet, és vándorútra keltem, hogy megleljem a mesebeli Kábeltévés Internetet, amiről már oly sokat lehetett hallani a Magyar Királyságban. Akkoriban a környéken lakott vala egy szeszélyes varázsló, akit tvnet-nek hívtak. Hosszú és kalandos úttal el is jutottam pedig eme varázsló vállalati telephelyére, és esdve kértem, hogy Kábeles Internetét ossza meg velem bőkezű aranyamért cserébe.

Mondotta pedig vala erre a tvnet: Bizony mondom, nem részesülhetsz az internetem áldásában, mert lakhelyeden nem található a Szent Csillagpontos Kábel. Így te örökre a gonosz Fatáv karmaiban fogsz sínylődni, megváltásra hiába várva.

Sajátos módon, ahol laktam, már volt egy kábeltévé szolgáltató. Eme szolgáltató a legjobb 5 német csatornát bocsájtotta a lakosság rendelkezésére, fejlesztésekbe nemigen bonyolódott, és a csillagpontos hálózatról még csak nem is hallottak. Így is maradt mindez igen sokáig.

A történet ott vesz vidám fordulatot, amikor eljött a Királyi Magyarországra egy új, külföldi, és nagy, "Tőke" nevű varázspálcával rendelkező, hatalmas mágus. Már a neve is idegenül csengett, és most nem is jut pontosan eszembe (mindenesetre három betűből állt, amiből az első a "U" az utolsó pedig a "C" volt). Ez az új varázsló pedig (sok-sok keményen bányászott aranyunkért cserébe) teremtett vala csillagpontos hálózatot.


To be continued...

...when?


2008-10-25 A VinyóAzApocalypseba akciócsoport tevékenysége óta több, mint két év telt el. Nos, a mai nap az ApocalypseRulezOrg újabb fantasztikus lépést tett előre: 0.5GB-tól 1GB-ra upgrade-eltem a memóriáját. Erre egyebek között azért volt szükség, mert a szerver új, fokozottan közhasznú szerepet fog ellátni (várhatóan jövő héttől), amihez Mysql adatbázis is szükséges lesz. A plusz memória érezhetően javítani fog a szerver teljesítményén. Én már most érzem...


2008-12-14 Flöff. Szegény jó Hush Technologies gépecske, ami kb 3 éve húzta az ApocalypseRulezOrg igáját, ma hajnali 6 órakor meghalt. Béke poraira.

A tápegységen található led egyből kialszik, ha a gépet megpróbálom bekapcsolni. Maga a gép egy picit nyekken ilyenkor, aztán elhallgat. A diagnózis: rövidzár általi RigorMortis.

Vettem helyette egy másik PC-t, kb az egyetlen helyen, ami a környéken vasárnap délelőtt nyitva tartott (milyen mázli, hogy Karácsony közeleg!) Fáj a szívem szegény kis Hush-ért. JóMunkásEmber volt, csendes, nem kért sokat enni, ritkán panaszkodott. Szívünkben őrizzük emlékét.


2009-01-29: Megvolt az első komolyabb zűr az új géppel.

A probléma azzal kezdődött, hogy betelt a root (Windows-nyelven: C:\) partíció. Ez egyike azoknak a dolgoknak, amiket a linux nagyon rosszul visel. Az sem segített, hoyg az utolsó pillanatban kezdtem a /opt partícióra mozgatni néhány több gigás file-t.

A dolog vége az lett, hogy a gép nem tudott új programokat indítani, ami persze a halál egyik formája. (Nem fagyott le, meg semmi, de újraindítani sem lehetett, mert a "reboot" is egy program). Szóval: reset. Reset pedig után arra az örömteli állapotra jöttem rá, hogy van 1 db futó gépem, ami ugyan teker mint a szar kisangyal, de éppen az internetre nem akar felcsatlakozni. Ez egy szervernél hátrányos jelenségnek minősül...

A baj forrását is hamar sikerült meglelni: valamiért azt a hálókártyát, ami az internet fele mosolygott eddig, a gép szépen átnevezte a hangzatos "eth0_rename_ren" névre. Ehhez hasonló jelenség már előfordult: amikor az előző gép megflöffedt, akkor nevezte át "eth0"-ról (ami a "rendes" név) "eth0_rename"-re. Akkor ezzel nem foglalkoztam, csak kijavítottam a konfigurációs file-okban az eth0-t eth0_rename-re. Aztán ez így jó is volt, és többet nem foglalkoztam vele. (Tanulság: mindennel kell foglalkozni mindig.)

Sajnos miután a triviális és általam ismert megoldásokat kipróbáltam, belefutottam egy tyúk-vagy-tojás típusú problémába: ahhoz hogy a problémára megoldást találjak, a neten kellene keresnem, ellenben a probléma pont az, hogy nincs netem. Hála a laptopomnak és a környéken lakó ingyenwifis lakások egyikének, aztán megleltem a megoldást.

Röviden a gond az volt, hogy a /etc/udev alatt az eth0 hálókártyának még mindig a régi, halott gép hálókártyájának a hardver címe volt bejegyezve, így annak szépen fenn volt tartva az eth0. Ide beírtam az új gép új hálókártyájának a hardver címét, és hirtelen minden megjavult...


2011-05-03: Hardver hiba lépett fel!!

Konkrétan, letéptem a gép elejét. Azt hittem, hogy olyan típusú a gép háza, aminek lepattintható az elülső panele. Ami kiderült, hogy ez olyan típusú, aminek lepattintható a panele egyszer.

Szóval, szegény gépnek most nincsenek led kijelzői, nincs reset és bekapcsoló gombja. Azért működik, csak a ki-bekapcsoláshoz ki kell nyitnom a házat.

::Nekem egyszer egy dísztolltartóm járt így. Első napom volt az új sulimban, ötödikesként, miután Madridból hazajöttünk, és voltam olyan hülye, hogy egy mezei tolltartó helyett egy golyóstoll-töltőtoll párost vittem magammal, amit búcsúzóul kaptam ajándékba egy kinti haveromtól. Az egyik osztálytársam odajött, és a megfelelő mozdulat kíséretében rákérdezett, hogy a tollak dobozának a teteje leszedhető-e? Nos, attól a naptól fogva leszedhető volt...SAdam

:Szia Upi! Van otthon nem kellő ATX házam. Vagyis nem az enyém, de a gazdája 110% hogy odaadja. - Grizli


2012-02-28 7:43: Flöff! Megdöglött szegény apocalypse tápja :( Béke poraira!

Egy ideje úgyis terveztem az oldal költöztetését egy VPS-re, hát.. eljött az ideje. Ezeket a sorokat már az új VPS-en írom.

Update 13:02: Meglehetősen bizonyos vagyok benne, hogy az ApocalypseKÖZÖS, Maliusz és a levelezésből Ulmar, SAdam és saját fiókjaimat sikerült átmentenem a VPS-re. Kezdem úgy érezni, hogy a VPS "az" ApocalypseRulezOrg, és nem a romos, szétszedett gép a szomszéd szobában. Hátra van még a CitiesOfApocalypse, BNC mindenféléje, meg még a jóisten tudja mi minden, ami a szerveren elfekvőben volt.

Aki még szeretné használni az apocalypse-es címét, vagy át szeretné irányítani valamilyen másik címre, az szóljon!


2012-03-13: A VPS migrálás óta elég kellemetlen I/O problémákkal küszködik a szerver. Gondoltam, bemásolom ide a szolgáltatóval folyó levelezésemet, tanulságképpen:

01/03/2012 18:35 UPi || Client

Dear sir/madam,

I am experiencing intermittent IO problems on my VPS. The problem manifests in one or more processes stalling completely for several seconds at a time. I am using 222k of the memory available, leading me to believe that it is not a RAM issue.

Are you aware of any issues impacting the host computer?
Is there a way I can tweak my VPS settings to fix this problem?

I am using debian Squeeze.

Best regards,
UPi
01/03/2012 18:40 Cristian Tomoiaga || Staff

Hello,

There doesn't seem to be any issues currently with the server you are on. Infact the I/O is pretty low at this time.
How often did you see the issues. When your application stalls can you read / write to the storage ?
Are you sure this is storage related , did you check if you are not using too much CPU for example ?

Regards,
Cristian Tomoiaga - IntoVPS
01/03/2012 18:44 UPi || Client

Thank you for your quick response.

I was suspecting I/O mostly because all other usage (CPU and RAM) were low at the time. I am running a screen session, and I could change to a page where top was running, so it wasn't a network issue either. I also noticed that the problem happened relatively often with bash when I was using tab completion.

How can I tell if I'm using too much CPU? (Other than keeping an eye on "top".) How much CPU use is "too much"?
01/03/2012 18:46 Cristian Tomoiaga || Staff

Hi,

Usually we can see if CPU is used or if other issues appear but it depends. Did you noticed the issue now or some time ago in the past ?

Regards,
Cristian Tomoiaga - IntoVPS
01/03/2012 19:00 Cristian Tomoiaga || Staff

Hi,

This may have been something temporary, however we will keep an eye on the server.
We will also add new hardware in the following week to isolate anyone who is causing I/O and affecting others so you should see an increase in performance and I/O after that.

Regards,
Cristian Tomoiaga - IntoVPS
02/03/2012 18:10 UPi || Client

Thank you for your followup!

Unfortunately the problem still persists. I have been unable to narrow down the exact circumstances, it seems sporadic. When it happens, though, I see a wait state on top that is close to a multiple of 25%, e.g. it is something like 24.6% or 75%. It also seems certain that not the entire VPS is I/O blocked; other processes seem to run quite happily, and I can even spawn new processes.

About past experiences: I'm afraid I do not have any. I haven't been using the VPS much until recently.
02/03/2012 18:38 Cristian Tomoiaga || Staff

Hi,

We will schedule the migration of your VPS to a new node in the following days. The migration will not affect the VPS data or uptime, except for a reboot that we will perform and that may take a few seconds (usually 10).

Regards,
Cristian Tomoiaga - IntoVPS
02/03/2012 18:40 UPi || Client

Thank you, your help is much appreciated.
07/03/2012 22:55 UPi || Client

Please do the migration soon. The problem still persists and is fairly annoying.
07/03/2012 23:01 Alexandru Rusu || Staff

Hello,

We will update this ticket when the migration has started.

Regards,
Alexandru Rusu - IntoVPS
11/03/2012 14:52 UPi || Client

Can you please give me a timeline about the migration? I am getting frustrated with this continued problem.
11/03/2012 15:10 Alexandru Rusu || Staff

Hello,

As I'm aware at this time we haven't added new hardware in this facility, however as soon as we do, you're first on our priority list.

Regards,
Alexandru Rusu - IntoVPS
11/03/2012 15:18 UPi || Client

Thank you, I appreciate that.

However, your colleague, Cristian Tomoiaga, wrote "will schedule the migration of your VPS to a new node in the following days". That was over a week ago, and I would be happy if you could give me an estimate as to when this will happen!

Failing that, I would also have any hints you can give me to mitigate the problem on my end. It is really rather annoying!
11/03/2012 15:48 Alexandru Rusu || Staff

Hello,

I have just checked the IO performance and couldn't spot a issue at this time. Also I've checked the beancounters file and it's looks just fine.

Regards,
Alexandru Rusu - IntoVPS
11/03/2012 15:49 UPi || Client

I suppose that is good news. However, it doesn't explain why random processes stall for 30s or more.
11/03/2012 16:17 Alexandru Rusu || Staff

Hello,

Until the migration we're trying to pinpoint the issue. I have forwarded this to my colleagues as well.

Regards,
Alexandru Rusu - IntoVPS
12/03/2012 16:07 UPi || Client

On further thing I noticed is that the stalling is accompanied by affected processes (sometimes several at a time) showing up in CPU STAT "D" (uninterruptible sleep) in "top". I hope this helps pinpoint the issue, because I'm out of ideas here. This is not happening in any of my other 5 VPS's, including the two that I have with you (startvox.com and csodalampa.hu). It's bizarre.
12/03/2012 16:14 Cristian Tomoiaga || Staff

Hello UPi,

Thank you for letting us know. We will investigate further. We will also migrate your VPS until tomorrow on a new node.

Regards,
Cristian Tomoiaga - IntoVPS
12/03/2012 16:15 UPi || Client

Thank you.
13/03/2012 17:48 UPi || Client

It is very much tomorrow.
13/03/2012 17:52 Zoltan Sandor || Staff

Hello,

We will start the migration as soon as we have the new servers online, probably a few hours.

Best regards,
Zoltan Sandor.

AdminisztrációTéma

Tagek: